#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?'commodity'02)_(?'market'\w{3,})_(?'tenortype'Q)(?'offset'[1-9][0-9]?)?_(?'derivative'PHY|FUT) (?'period'Q)-(?'year'\d{4})-\b(?'month'[1-4])\b$"
Local $sString = "02_AUT_Q_PHY Q-2015-1" & @CRLF & _
"02_GASPOOL_H_Q_PHY Q-2015-2" & @CRLF & _
"02_GASPOOL_L_Q_PHY Q-2015-3" & @CRLF & _
"02_NBP_Q_PHY Q-2015-4" & @CRLF & _
"02_MGP_Q_PHY Q-2015-1" & @CRLF & _
"02_NCG_H_Q_PHY Q-2015-2" & @CRLF & _
"02_NCG_L_Q_PHY Q-2015-3" & @CRLF & _
"02_OTE_Q1_PHY Q-2015-4" & @CRLF & _
"02_POLVP_Q1_PHY Q-2015-1" & @CRLF & _
"02_PEGN_Q1_PHY Q-2015-2" & @CRLF & _
"02_SVKVP_Q1_PHY Q-2015-3" & @CRLF & _
"02_TTF_H_Q2_PHY Q-2015-4" & @CRLF & _
"02_ZEEBRUGGE_H_Q9_PHY Q-2015-1" & @CRLF & _
"02_ZTP_H_Q10_PHY Q-2015-2" & @CRLF & _
"02_ZTP_L_Q99_PHY Q-2015-3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")