$re = '/\b(?:(?:Mr|Miss|dr|lord)? )?(\w+(?:[ -]\w+)*)\b/m';
$str = 'Mr Bob Smith
Miss Jessica Blue
tim white
dr Lisa S pink
lord Lee Kensington-Smithe';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);