#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^([a-zA-Z]+)\s*\{(.*?)}(?=\n[a-zA-Z]+\s*{\n|\Z)"
Local $sString = "BackdropNode {" & @CRLF & _
" inputs 0" & @CRLF & _
" name BackdropNode6" & @CRLF & _
" tile_color 0x555555ff" & @CRLF & _
" label RDN" & @CRLF & _
" note_font_size 42" & @CRLF & _
" xpos -1136" & @CRLF & _
" ypos -4272" & @CRLF & _
" bdwidth 451" & @CRLF & _
" bdheight 529" & @CRLF & _
"}" & @CRLF & _
"Write {" & @CRLF & _
" file "\[value project_directory]/_output_/\[string range \[file tail \[value root.name]] 0 20].mov"" & @CRLF & _
" colorspace sRGB" & @CRLF & _
" raw true" & @CRLF & _
" file_type mov\{(.*?)\}" & @CRLF & _
" mov64_format "mov (QuickTime / MOV)"" & @CRLF & _
" mov64_codec AVdh" & @CRLF & _
" mov64_dnxhd_codec_profile "DNxHD 422 8-bit 145Mbit"" & @CRLF & _
" mov64_dnxhr_codec_profile "SQ 4:2:2 8-bit"" & @CRLF & _
" mov64_pixel_format {{0} "yuv420p\tYCbCr 4:2:0 8-bit"}" & @CRLF & _
" mov64_quality High" & @CRLF & _
" mov64_advanced 1" & @CRLF & _
" mov64_write_timecode true" & @CRLF & _
" mov64_gop_size 12" & @CRLF & _
" mov64_b_frames 0" & @CRLF & _
" mov64_bitrate 20000" & @CRLF & _
" mov64_bitrate_tolerance 40000000" & @CRLF & _
" mov64_quality_min 2" & @CRLF & _
" mov64_quality_max 31" & @CRLF & _
" render_order 3" & @CRLF & _
" checkHashOnRead false" & @CRLF & _
" version 132" & @CRLF & _
" in_colorspace scene_linear" & @CRLF & _
" out_colorspace scene_linear" & @CRLF & _
" name Write2" & @CRLF & _
" xpos -1025" & @CRLF & _
" ypos 2230" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")