import re
regex = re.compile(r"^( )(.+)", flags=re.MULTILINE)
test_str = ("RegExr was created by gskinner.com, and is proudly hosted by Media Temple.\n\n"
" Edit the Expression & Text to see matches. Roll over matches or the expression for details. PCRE & Javascript flavors of RegEx are supported.\n\n"
"The side bar includes a Cheatsheet, full Reference, and Help. You can also Save & Share with the Community, and view patterns you create or favorite in My Patterns.\n\n"
" Explore results with the Tools below. Replace & List output custom results. Details lists capture groups. Explain describes your expression in plain English.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")