$re = '/^(\d(?=,),\d|\d)/m';
$str = '341536798
2,541536798
14,54153';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);