$re = '/(?s)^[^-]*-(.*)-[^-]*$/m';
$str = 'I AM -VERY- HUNGRY';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;