$re = '/^HP: \[(\d+)\/(\d+)\], SP: \[(\d+)\/(\d+)\], EP: \[(\d+)\/(\d+)\]$/m';
$str = 'HP: [352/352], SP: [137/421], EP: [327/385]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);