import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\\\"select\\\"[\\w\\d\\s\\\"=]*><a href=[\\w\\d\\s\\\"<>:/.-]+</a></span>";
final String string = "<span class=\"select\" foo=\"1\"><a href=\"https://www.domain.tld\">Word 1</a></span><span class=\"select\"><a href=\"https://www.domain.tld\">Word 2</a></span><span class=\"no_select\"><a href=\"https://www.domain.tld\">Word 3</a></span><span class=\"select\" bar=\"2\"><a href=\"https://www.domain.tld\">Word 4</a></span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}