const regex = /AddAgenda\(\"([^"]+)\",\s*\{(\s*([\w_]+)\s*,?\s*([\w_]+)\s*)},\s*{\s*(([\w_]+)\s*,?\s*([\w_]+)?\s*,?\s*([\w_]+)?)\s*}\s*\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('AddAgenda\\(\\"([^"]+)\\",\\s*\\{(\\s*([\\w_]+)\\s*,?\\s*([\\w_]+)\\s*)},\\s*{\\s*(([\\w_]+)\\s*,?\\s*([\\w_]+)?\\s*,?\\s*([\\w_]+)?)\\s*}\\s*\\)', 'g')
const str = `AddAgenda("Gangster's agenda",
{
TEAM_HITMAN,
TEAM_POLICE
},
{
TEAM_GANG,
TEAM_MAFIA,
TEAM_GANGSTER
})
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}