$re = '/(?<orderNum>\d+)(?=\/Order)/m';
$str = '/Contact/v1/15965755/Order';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);