re = /=([^'"\n]*|(?:"[^"\n]*")|(?:'[^'\n]*'))$/m
str = 'positive:
="..."
=\'...\'
=...
="...\'..."
=\'..."...\'
negative:
="...\'
=\'..."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end