$re = '/\b(мир)\b/u';
$str = 'мир памир мир, мирный мир.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);