$re = '/(http:\/\/[\d]{1,3}.[\d]{1,3}.[\d]{1,3}.[\d]{1,3})/m';
$str = 'http://127.0.0.1:48249/api';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);