using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Thumb[^\/]*\.jpg";
string input = @"Thumb abc/def/Thumb hi.jpg
Thumb abc/def/ghi.jpg";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}