re = /^(?!.*,.*,).*(?:[^,]|^)$/m
str = 'I am not very good at regex and I need
I am not very good at regex, and I need
I am not very good at regex, and I need,
I am not very good at regex, and, I need
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end