using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import(?:[\s.*]([\w*{}\n\r\t, ]+)[\s*]from)?[\s*](?:[""'](.*[\w]+)[""'])?";
string input = @"import {
Component
} from '@angular2/core';
import defaultMember from ""module-name"";
import * as name from ""module-name "";
import { member } from "" module-name"";
import { member as alias } from ""module-name"";
import { member1 , member2 } from ""module-name"";
import { member1 , member2 as alias2 , member3 as alias3 } from ""module-name"";
import {
Component
} from '@angular2/core';
import defaultMember from ""$module-name"";
import defaultMember, { member, member } from ""module-name"";
import defaultMember, * as name from ""module-name"";
import * as name from ""module-name ""
import { member } from "" module-name""
import { member as alias } from ""module-name""
import { member1 , member2 } from ""module-name""
import { member1 , member2 as alias2 , member3 as alias3 } from ""module-name""
import {
Component
} from '@angular2/core'
import defaultMember from ""$module-name""
import defaultMember, { member, member } from ""module-name""
import defaultMember, * as name from ""module-name""
import ""module-name"";
import React from ""react""
import { Field } from ""redux-form""
import ""module-name"";
import {
PlaneBufferGeometry,
OctahedronGeometry,
TorusBufferGeometry
} from '../geometries/Geometries.js';
import {
PlaneBufferGeometry,
OctahedronGeometry,
TorusBufferGeometry
} from '../geometries/Geometries.js'
import(""whatever.js"");
import(""whatever.js"")
import { Field } from ""redux-form"";
import MultiContentListView from ""./views/ListView"";
import MultiContentAddView from ""./views/AddView"";
import MultiContentEditView from ""./views/EditView"";
import { Field } from ""redux-form""
import MultiContentListView from ""./views/ListView""
import MultiContentAddView from ""./views/AddView""
import MultiContentEditView from ""./views/EditView""
<MenuItem value=""^$"" primaryText=""Não exibir importados"" />
<MenuItem value=""\\w+"" primaryText=""Exibir importados"" />
// *Add all needed dependency to this module
// *app requires those import modules to function
*/
/**
*
*Add all needed dependency to this module
*app requires those import modules to function
*
**/
let modules = [];";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}