#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^!\w+\s+\w+\s+"
Local $sString = "!wordOne wordTwo THE REST OF THE SENTENCE WHICH COULD BE LONG"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)