$re = '/(^|[^\d]+)51([^\d]+|$)/';
$str = '12,2,41,51,8,53';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);