package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[1-478][0-9]{2}(0[1-9]|1[0-2]|62|63)(2[ABab]|[0-9]{2})(00[1-9]|0[1-9][0-9]|[1-8][0-9]{2}|9[0-8][0-9]|990)(00[1-9]|0[1-9][0-9]|[1-9][0-9]{2})(0[1-9]|[1-8][0-9]|9[0-7])?$`)
var str = `193104221833161`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}