using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![final|import])static(?!\s*final)(?!.*{)";
string input = @"public static final String
final static String
static String
static String
static final String
static final String
import static org.
private static boolean someMethod() {";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}