package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)test(maybe)?test`)
var str = `testmaybetest
testmaytest
testtest`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}