use strict;
my $str = 'cddefga1bcd2345ea1ABCa1DEFa1
ABBC1abdrFECsarR1C1abdrFECsarR1
r1uaysdhahsaz1r1uaysdhahsaz1r1uaysdhahsaz1';
my $regex = qr/^.*?\K[A-Za-z]1.*?[A-Za-z]1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}