re = /^@\w+\b(?!.*@)/m
str = '@username!&?()*^
@username@username
@username!?>@
not@username
!@username
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end