import re
regex = re.compile(r"\.?\w+(?=\()", flags=re.MULTILINE)
test_str = ("doc_name <-\n"
" officer::read_docx() %>% \n"
" flextable:::body_add_flextable(table_to_save) %>% \n"
" print(target = \"word.docx\")\n\n"
".libPaths()\n"
".test()\n\n"
"c(\"a\", \"b\")\n\n"
"package::function()$field")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")