$re = '/^[0-9]{5}(?!-0000$)(?:-[0-9]{4})?$/m';
$str = '12345
12345-1234
12345-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);