package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:apple|apples|pear|pears|strawberry|strawberries|grape|grapes)\b`)
var str = `Today I ate an apple, then a pear, then a strawberry. This is my article and it's about apples and pears. I like strawberries as well though.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}