package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)flyheight.com\/videos\/(y.*)`)
var str = `https://flyheight.com/videos/ybb347
https://flyheight.com/videos/yb24os
https://flyheight.com/public/images/videos/793f77362f321e62c32659c3ab00952d.png
https://flyheight.com/videos/5o6t98/#disqus_thread
https://flyheight.com/videos/yb24os
https://flyheight.com/videos/ybb347`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}