$re = '/<variable\s[^>]*?name=[\'"]test[\'"][^>]*>(.*?)<\/variable>/m';
$str = '<variable style="background-color:red;" name="test" data-id="2">Variable <variable> outra tag variable </variable> Test2</variable> outro texto';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);