$re = '/(?<=")[^"]+(?="[^"]*$)/m';
$str = '("NNNS" lllsds 4.5 ddsdsd "DDEERR")';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);