$re = '/(?<=chk-).+?(?=-)/m';
$str = 'chk-1-UFEDAnalyticsDesktop ghtml-Class chk-2-UFEDAnalyticsWorkgroup chk-3-UFEDAnalyticsEnterprise';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);