import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=^)|(?<=\\s))(?:(?:ht|f)tps?://)?(?!\\d+\\.)((?:[^\\W_]|-)[^\\W_]*(?:-[^\\W_]*)*(?:\\.(?:[^\\W_]|-)[^\\W_]*(?:-[^\\W_]*)*)*\\.[^\\W_][^\\W_]*)(?:\\s|$)";
final String string = "IP Address:\n"
+ "93.114.205.169\n"
+ "0.0.0.0\n"
+ "0.0.0.0\n"
+ "10.10.10.10\n"
+ "99.99.99.99\n"
+ "199.199.199.199\n"
+ "255.255.255.255\n"
+ "256.256.256.256\n"
+ "02.02.02.02\n"
+ "111.222.13.255\n"
+ "1.2.3.4\n"
+ "1.2.3.4.5\n"
+ "11.22.33.44\n"
+ "11.22.33.44.55\n"
+ "255.0.1.254\n"
+ "255.0.1.254\n"
+ "In a text 255.0.1.254 there is an IP address\n"
+ "In a text 10.10.10.10 there is an IP address\n"
+ "In a text 93.114.205.169 there is an IP address\n\n"
+ "Domain:\n"
+ "example.com\n"
+ "https://sub5-7.example.com/\n"
+ "https://sub5-7.example.com\n"
+ "sub.sub2.example.com\n"
+ "www.example.com\n"
+ "https://sub.example.com\n"
+ "http://example.com\n"
+ "ftp://sub.mit-example222.com\n"
+ "In a text www.example.com there is an domain.\n"
+ "In a text https://sub5-7.example.com there is an domain.\n"
+ "In a text www.example.com there is an domain.\n\n"
+ "URL\n"
+ "93.114.205.169/path\n"
+ "example.com/path\n"
+ "sub.example.com/path\n"
+ "93.114.205.169/path\n"
+ "https://sub5-7.example.com/\n"
+ "http://example.com/\n"
+ "example.com/\n"
+ "sub.example.com/\n"
+ "www.--example.com/\n"
+ "www.examp--le.com/\n"
+ "www.example.co/\n"
+ "www.example.c/\n"
+ "example.com/path\n"
+ "sub.example.com/path\n"
+ "sub.example.com/path\n"
+ "sub.example.com/path\n"
+ "sub.example.com/path/path/path/p/a/q/1$%h\n"
+ "sub.example.com/path/path/path/p/a/q/1$%1fh\n"
+ "sub.example.com/path/path/%aa%1f%3dpath/p/a/q/1$%1fh\n"
+ "https://sub.example.com/path/path\n"
+ "http://sub.example.com/path/path\n"
+ "http://something.com/#$SLJFHsdq32908432098=!~abc\n"
+ "In a text example.com/path there is an URL path.\n"
+ "In a text www.example.com/path there is an URL path.\n"
+ "In a text www.blog.example.com/path there is an URL path.\n"
+ "In a text sub.example.com/paththere is an URL path.\n"
+ "In a text sub.example.com/path/path/path/p/a/q/1$%h there is an URL path.\n"
+ "In a text sub.example.com/path/path/path/p/a/q/ there is an URL path.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}