$re = '/data:\s*(.*)/';
$str = 'data: {"id":"cmpl-7UGNKhpHRPBvdilqMvoUgxGM2EiYO","object":"text_completion","created":1687447142,"choices":[{"text":"","index":0,"logprobs":null,"finish_reason":"stop"}],"model":"text-davinci-003"}
data: [DONE]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);