$re = '/\/(HEAD|(info\/refs)|(objects\/info\/(alternates|http-alternates|packs))|(objects\/[0-9a-f]{2}\/[0-9a-f]{38,62})|(objects\/pack\/pack-[0-9a-f]{40,64}\\\\\\\\\.(pack|idx))|(git-(upload|receive)-pack))$/m';
$str = '/HEAD
/info/refs
/objects/info/alternates
/objects/info/http-alternates
/objects/info/packs
/objects/aa/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
/objects/aa/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
/objects/pack/pack-aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\\\\.pack
/objects/pack/pack-aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\\\\.idx
/objects/pack/pack-aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\\\\.pack
/objects/pack/pack-aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\\\\.idx
/git-upload-pack
/git-receive-pack';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);