#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\( (.*)(\([A-Za-z0-9,\-]+\))_(.*) - (Google Chrome|Internet Explorer)\)"
Local $sString = "( 终端知识库 - Google Chrome)" & @CRLF & _
"( 荣耀盒子Pro_电视画面显示不满屏、比例失调或超出屏幕显示区域怎么办? - Google Chrome)" & @CRLF & _
"( 多屏互动是什么功能?不同手机如何与盒子进行多屏互动? - Google Chrome)" & @CRLF & _
"( 【维修配件价格查询】 - 华为服务与支持 - 华为手机官网 - Google Chrome)" & @CRLF & _
"( 华为消费者业务官网-服务与支持 - Google Chrome)" & @CRLF & _
"( M2是否支持皮套模式,怎么开启皮套模式 - Google Chrome)" & @CRLF & _
"( 荣耀X2(GEM-703L,GEM-703LT)_为什么设置里面有两个IMEI? - Internet Explorer)" & @CRLF & _
"( 荣耀6(H60-L01)_电池无法正常充电,如何解决? - Internet Explorer)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")