$re = '/(\s*)(?=\.\w{3})/i';
$str = 'as.asd.sd fdsfs. dfsd d.sdfsd. sdfsdf sd .COM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);