re = /((?:.*)[aeiouAEIOU]+(?:.*)[ ]+(?:.*))|(?:.*)[ ]+((?:.*)[aeiouAEIOU]+(?:.*))/
str = '
k adfa
a adfadfkdf a sk
k aeiou
asdfsdf
a
a
b
b
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end