using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(queryStringParameters=[^&]*&?)";
string input = @"/geoinfo/weather/current/-83.442836,-214.974261?queryStringParameters=dddd&name1=sdasdas&queryStringParameters=2222";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}