$re = '/^(\d|\d+[.,]?\d+)$/m';
$str = '123
12.3
1,23
12.
.123
1...2
1.2.3.3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);