$re = '/^(?!0\d+)\d+/m';
$str = '111
0
013
120
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);