$re = '/^(htt|www\.)(?!.*\1).*$/m';
$str = 'http://www.sample.com
https://www.sample.com
http://www.sample.com/xyz
www.sample.com
www.sample.com/xyz/#/xyz
sample.com
www.sample.com
mofiz.com
kolim.com
www.murikhao.www.sample.com
http://murihao.www.sample.com
http://www.sample.com/xyz?abc=dkd&p=q&c=2
www.sample.gov.bd
www.sample.com.en
www.sample.vu
https://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1t5OJ?ver=c8b4
https://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1t5OJ?ver=c8b4https://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1t5OJ?ver=c8b4
www.msft.com
http://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1XqlR?ver=b1bchttp://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RW6fET?ver=80af
http://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1XDkS?ver=6779https://img-prod-cms-rt-microsoft-com.akamaized.net/cms/api/am/imageFileData/RE1Etgg
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);