$re = '/(?<!\d)\d{3}(?!\d)/';
$str = '4473 333hello 564 394844he hello123 12344 43433 343';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);