re = /^(?!.*\/[0-9A-F]{40}\/).*$/m
str = '/dev/api/appid/A1B2C3D4E5A1B2C3D4E5A1B2C3D4E5A1B2C3D4E5/users
/dev/api/apps/list
/dev/api/help/apps/applicationname/apple/osversion/list/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end