$re = '/\b(?:([1-9])0\10\10|0([1-9])0\20\2)\b/m';
$str = '101010
020202';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);