$re = '/^(?:[A-z0-9]+-?)+(?=-)/m';
$str = 'test-title-PeG9
test--title-PeG9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);