use strict;
my $str = '/google.com/er/re';
my $regex = qr/(?!^\/)(\/)/p;
my $subst = '%';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";