package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\[[^][]*])`)
var str = `[10:42-23:10]part1[11:30-13:20]part2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}