// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sU)<h.*>.*<a.*href='(.*)'>.*<\/a>.*<\/h.*>").unwrap();
let string = "<h1 class='blablabla'><a class='Title' href='https://www.url.com' rel='rel'>blablabla</a></h1>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}