const regex = /<img[^>]+src\s*=\s*['"]([^'"]+)['"][^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img[^>]+src\\s*=\\s*[\'"]([^\'"]+)[\'"][^>]*>', 'gm')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit. Duis bibendum lorem bibendum lectus rhoncus molestie. <img src ="aaaa" /> Maecenas ipsum justo, fermentum nec lacus in, porta consectetur metus.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}