$re = '/(?<!\/\/.)".*?[^\\\\]"/';
$str = '// "No Match"
MessageBox.Show($"Test \\"{Path.GetFileName(Test)}\\"Right?", "TEst", MessageBoxButtons.YesNo, MessageBoxIcon.Asterisk);';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);